Close
Login to Your Account
Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2018
    Location
    Seattle
    Posts
    21
    Downloads
    0
    Uploads
    0

    Thumbs up SST 768 Blower mounted on head failure?

    Hello everyone! Unclogged the build material, pretty easy once you do it once. Hopefully that doesn't happen all the time. I ran a fairly lengthy print and noticed the fan/blower mounted on the head is not moving. So far I've never once seen it spin, either upon heating up or while printing.. When is it suppose to spin, and when is it not..

    Thank you!

  2. #2
    Join Date
    Jan 2018
    Location
    Seattle
    Posts
    21
    Downloads
    0
    Uploads
    0
    Just following up, it was indeed dead. Swapped it out for another and worked right away.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NEED HELP Failure mode for loading fail that happens quickly
    By cosmicaug in forum Stratasys
    Replies: 0
    Last Post: 08-31-2018, 12:20 PM
  2. NEED HELP Serious problem.. Print failure at specific layer. Please help..
    By Psychophoria in forum Beginners (New to 3D Printing)
    Replies: 1
    Last Post: 03-28-2018, 08:37 AM
  3. Replies: 1
    Last Post: 01-23-2017, 09:47 AM
  4. Hot end mounted to THK HSR25 sliding block
    By Galane in forum DIY 3D Printer Machine Mechanics
    Replies: 0
    Last Post: 08-27-2015, 10:47 PM
  5. Working squirrel-cage (centrifugal) fan blower
    By Warren_3Deee in forum 3D Models & Print Gallery
    Replies: 6
    Last Post: 04-08-2014, 11:57 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •